Benutzerdefinierte Suche

Excel: Wochentag berechnen mit der Excel-Funktion WOCHENTAG

Die Excel-Funktion WOCHENTAG ist eine Möglichkeit, den Wochentag in Excel anzuzeigen.

Die Wochentag-Berechnung in Excel haben wir in vier Bereiche unterteilt.
Methode 3 mit der Excel-Funktion WOCHENTAG wird hier vorgestellt.

Hintergrund­wissen:Für Excel ist ein Datum eine Zahl
➜ Methode 1:In Excel Datum als Wochentag formatieren
➜ Methode 2:Wochentag berechnen mit der Excel-Funktion TEXT
➜ Methode 3:Wochentag berechnen mit der Excel-Funktion WOCHENTAG
Methode 1 Methode 2 Methode 3
Zelleninhalt
(wichtig z.B. für WENN-Funktion)
Datum Text "Montag" etc. Zahlen 1 bis 7
Sortierung standardmäßig Datum alphabetisch Sonntag-Samstag
Benutzerdefinierte Sortierung z.B. Montag-Sonntag

Wochentag mit der Excel-Funktion WOCHENTAG berechnen

Das Ergebnis der Funktion WOCHENTAG ist eine Zahl zwischen 1 und 7, die erst einmal nichts mit einem Wochentag zu tun hat. In einem zweiten Schritt muss man das Ergebnis so formatieren, dass ein Wochentag an Stelle der Zahl angezeigt wird.

Die Syntax der Funktion lautet: =WOCHENTAG(Zahl;[Typ])

ZAHL ist das Datum, welches man in einen Wochentag umwandeln möchte. Dies kann sein ein Bezug auf eine Zelle oder ein Datum, das in "" geschrieben werden muss.
Mit TYP legt man fest, welche Zahlen welchen Wochentagen zugeordnet sein sollen. Der TYP 1 bedeutet beispielsweise, dass die 1 dem Sonntag entspricht, 2 dem Montag und so weiter. Bei TYP 2 wird der 1 der Montag zugeordnet, und der 7 der Sonntag.
Der Typ steht in eckigen Klammern, muss somit nicht angegeben werden. Gibt man den Typ nicht an, wird automatisch der TYP 1 gewählt.
WICHTIG: Möchte man das Ergebnis hinterher als Wochentag formatieren, muss man unbedingt den TYP 1 auswählen, ansonsten ist die Ausgabe der Wochentage falsch.
Excel Funktion WOCHENTAG

Formatiert man das Ergebnis der Wochentags-Funktion vom Typ 1 als Datum, erhält man als Ergebnis Spalte B. Dies funktioniert, weil die Zahl 1 dem Datum 01.01.1900 entspricht, und das war gemäß Excel (fälschlicherweise) ein Sonntag (siehe Erklärung in Wochentag berechnen in Excel).
Egal, wie die Zahl 1 in einer Zelle zustande kommt (Datum 1.1.1900, manuelle Eingabe oder Berechnung über eine Funktion), eine 1 ist für Excel bei Formatierung als Wochentag ein Sonntag.

Über das Register START Gruppe ZAHL kann man das Dialogfenster ZELLEN FORMATIEREN Reiter ZAHL öffnen.
Excel Funktion WOCHENTAG als Wochentag formatieren

Wenn man nur den Wochentag anzeigen lassen möchte, muss man sich dieses Format selbst erstellen. Dies geht über den Punkt BENUTZERDEFINIERT. Hier arbeitet man mit den Platzhaltern T, M und J für Tag, Monat und Jahr. Um sich nur den Wochentag anzeigen zu lassen, trägt man bei Typ TTTT ein.

Trägt man statt TTTT nur dreimal das T ein (also TTT), dann erhält man den abgekürzten Wochentag Wochentag (Mo, Di …).

Auch wenn man nun den Wochentag sieht, ist das Ergebnis, das in der Zelle steht, immer noch eine Zahl zwischen 1 und 7. Es ist also nicht möglich, mit Funktionen auf den Namen des Wochentags zurückgreifen, sondern nur auf die Zahl. Die Funktion =WENN(B2="Sonntag"; "Zuschlag";0) führt also nicht zum gewünschten Ergebnis. Stattdessen muss man schreiben =WENN(B2=1;"Zuschlag";0).

Sortieren von Spalten, die mit der WOCHENTAG-Funktion berechnete Wochentage enthalten

Es ist möglich, die Spalte TAG sowohl nach Datum als auch nach Wochentag sortieren zu lassen.

Über die Schaltfläche Excel sortieren und filtern des Registers START Gruppe BEARBEITEN oder über Excel sortieren des Registers DATEN Gruppe SORTIEREN UND FILTERN gelangt man zum Dialogfenster (Benutzerdefiniertes) SORTIEREN.

Wochentag Sortierung Sonntag, Montag, Dienstag, Mittwoch, Donnerstag, Freitag, Samstag

Standardmäßig wird für die Spalte TAG die Sortierung nach dem Datum angezeigt, also nach den Zahlen 1 bis 7. Die Sortierung nach dem Datum beginnt somit mit dem Sonntag, da dieser ja der Zahl 1 entspricht.

Excel Wochentage sortieren ab Sonntag
Anmerkung: In den USA und einigen anderen Ländern ist übrigens der Sonntag auch der erste Tag der Woche - so wie in Deutschland bis 1975. Für Amerikaner ist das Ergebnis der Sortierung nach Datum somit korrekt.


Wochentag Sortierung Montag, Dienstag, Mittwoch, Donnerstag, Freitag, Samstag, Sonntag

Soll die Sortierung allerdings bei Montag beginnen (gemäß ISO 8601, die auch in Deutschland gilt), muss man über das BENUTZERDEFINIERTE SORTIEREN… gehen und dort die BENUTZERDEFINIERTE LISTE… aufrufen.
Excel Datum mit benutzerdefinierter Liste sortieren

In dem folgenden Dialogfenster kann man dann die Sortierung ab Montag auswählen.
Excel Wochentage sortieren ab Montag

Ihr Feedback zu
Excel Wochentag berechnen - Excel-Funktion WOCHENTAG
Nutzen Sie Google+? Dann können Sie Ihr Feedback auch gerne auf unserer Google+ Seite schreiben.
Ihre Mitteilung an Marion Schulz
Ihr Name oder Pseudonym: 
Dürfen wir Ihnen antworten? Bitte!!!!:-)
Ihre eMail-Adresse (optional): 

Weitere Informationen und Möglichkeiten zur Berechnung des Wochentags in Excel

Hintergrund­wissen:Für Excel ist ein Datum eine Zahl
➜ Methode 1:In Excel Datum als Wochentag formatieren
➜ Methode 2:Wochentag berechnen mit der Excel-Funktion TEXT
➜ Methode 3:Wochentag berechnen mit der Excel-Funktion WOCHENTAG
➜ Tipp:Datum in Excel formatieren

Feedback und Fragen zu Wochentagen in Excel oder zur Funktion WOCHENTAG?

, freiberufliche Dozentin für Microsoft Excel, Word und PowerPoint.

bitte bewerten
         
Bisher wurden 3 Bewertungen für diese Seite "Excel Wochentag berechnen mt Excel Funktion WOCHENTAG" abgegeben. Der Durchschnitt liegt bei 5.0 von 5 Sternen.
Alle Angaben ohne Gewähr

Anmerkungen, Vorschläge?